MPGS Degraded Performance
Incident Report for Paydock
Resolved
We would like to confirm that we have received a communication from MPGS that the service disruption identified for Mastercard Payment Gateway Services (MPGS) Asia Pacific (AP) gateway has been resolved.

It has been confirmed that there were no MPGS system errors in the past 1 hour after careful monitoring. Hence, we are closing this incident at this stage.
Posted Jul 26, 2023 - 14:39 UTC
Update
As we can see, the percentage rate decreased to 6.10% during the last half an hour. We are still monitoring the situation and awaiting communication from MPGS.
Posted Jul 26, 2023 - 13:32 UTC
Update
As we can see, the technical error rate has increased to 27.07% during the last half an hour. We haven't received any communication from the MPGS gateway yet. Nevertheless, we are monitoring the issue and will provide updates once we have them.
Posted Jul 26, 2023 - 13:10 UTC
Monitoring
As we can see, the percentage rate of errors has decreased to 6.48% during the recent hour. Nevertheless, we haven't received any reply from MPGS at the moment. We will keep monitoring the situation and keep you updated.
Posted Jul 26, 2023 - 12:35 UTC
Identified
At present, MPGS, one of our upstream providers, is experiencing a service issue that has caused a system error with the Payment service connection error. We were aware of the problem at 11:25 AM UTC.

We are actively monitoring the situation, and we have informed MPGS about the error, but we have not yet received a response from them. As per our checks, the error rates that have been identified at the moment are 22.83%.

We are keeping a close watch on the incident and will share further updates as soon as we receive them.
Posted Jul 26, 2023 - 11:34 UTC
This incident affected: Payment Services (MPGS gateway).