MPGS Degraded Performance
Incident Report for Paydock
Resolved
It has been confirmed that there were no MPGS system errors in the past hour after careful monitoring.

We have not received any communication from the MPGS gateway about the issue resolution, but we are considering this incident resolved at the moment.
Posted May 27, 2023 - 13:08 UTC
Monitoring
We are providing an update on the MPGS incident that was previously reported. Following thorough monitoring, no technical errors were found during our recent review. It appears that the issue has been resolved. However, we will continue to monitor the situation for another hour to ensure its final resolution.

Furthermore, if we receive any updates from MPGS regarding the issue, we will provide the information here to keep you informed.
Posted May 27, 2023 - 11:56 UTC
Identified
At present, MPGS, one of our upstream providers, is experiencing a service issue that has caused a system error with the 91 TIMED_OUT error code. We were made aware of the problem at 10:30 AM UTC, and it is still persisting.

We are actively monitoring the situation, and we have informed MPGS about the error (MPGS Case Number: 03765312), but we have not yet received a response from them. As per our checks, which are conducted every half an hour, the error rates have been fluctuating between 9% and 33%.

We are keeping a close watch on the incident and will share further updates as soon as we receive them.
Posted May 27, 2023 - 11:26 UTC
This incident affected: Payment Services (MPGS gateway).