MPGS Degraded Performance
Incident Report for Paydock
Resolved
It has been confirmed that there were no MPGS system errors in the past hour after careful monitoring.

We have not received any communication from the MPGS gateway about the issue resolution, but we are considering this incident resolved at the moment.
Posted Apr 28, 2023 - 18:37 UTC
Monitoring
We have received an update from the MPGS team concerning the matter:

"A service disruption identified for Mastercard Payment Gateway Services is still ongoing.

To: MPGS Asia Pacific, North America and Europe Contacts

When did the incident start?: 27 April 2023, 22:19 CT (03:19 UTC, 28 April 2023)

What is the impact?: Customer in Asia Pacific / Europe / North America regions may experience intermittent timeouts for Amex transactions via S2I acquirers. Teams are urgently working with external acquirer to mitigate the issue.

Mastercard Reference Number: INC000000305602

Communications Reference ID: 166318"

We will continue to monitor the situation and provide updates here as soon as any changes are made.
Posted Apr 28, 2023 - 10:11 UTC
Identified
One of our upstream providers, MPGS, is currently facing a degraded service issue resulting in a 91 TIMED_OUT gateway code. We became aware of this problem at 3 AM UTC and it is still ongoing.

We are continuously monitoring the situation, and MPGS has been notified of the error, although we are yet to receive a response from them.

Based on our half-hour interval checks, error rates have been fluctuating between 5% and 11%. We are closely monitoring the incident and will provide updates as soon as they are available.
Posted Apr 28, 2023 - 08:46 UTC
This incident affected: Payment Services (MPGS gateway).