MPGS Degraded Performance
Incident Report for Paydock
Resolved
We are pleased to inform you that, after a thorough assessment and close collaboration with MPGS, no ongoing errors or anomalies are observed from our side. The service disruption appears to be resolved, and we are closing this incident.

Thank you for your understanding and patience during this period.
Posted Oct 26, 2023 - 14:59 UTC
Monitoring
We appreciate your understanding and patience. We would like to inform you that we have received a response from Mastercard Gateway (MPGS) regarding the ongoing service disruption in the Asia Pacific region. According to their update, they acknowledge that the service disruption is still ongoing and may cause transaction latency/failures. The disruption began on 26 October 2023, at 05:14 CT (10:14 UTC).

As of our current assessment, we do not see any ongoing errors from our side. We are in close contact with MPGS and are actively working towards a solution. We will continue to keep you informed as we collaborate to resolve this matter.
Posted Oct 26, 2023 - 14:15 UTC
Identified
At present, MPGS, one of our upstream providers, is experiencing a service issue that has caused an error code SERVER_BUSY. We were aware of the problem at 11:55 AM UTC, and it is still persisting.

We are actively monitoring the situation, and we have informed MPGS about the error, but we have not yet received a response from them. As per our checks, which are conducted every half an hour, the error rates have been fluctuating between 6.13% and 9.17%.

We are keeping a close watch on the incident and will share further updates as soon as we receive them.
Posted Oct 26, 2023 - 12:38 UTC
This incident affected: Payment Services (MPGS gateway).