We are currently experiencing issues with Payment throughput.

Incident Report for Paydock

Resolved

Issues with Payment throughput were resolved at 3:23pm AEDT
Posted Oct 16, 2025 - 05:23 UTC

Monitoring

Platform stability has returned, we are currently monitoring.
Posted Oct 16, 2025 - 04:50 UTC

Investigating

We are currently experiencing issues with Payment throughput, we are investigating.
Posted Oct 16, 2025 - 04:18 UTC
This incident affected: Paydock Platform (Paydock API).