Platform Degradation - API and Dashboard

Incident Report for Paydock

Resolved

This incident has been resolved.
Posted Oct 16, 2025 - 06:49 UTC

Investigating

We are currently investigating reported Platform Degradation with API and dashboard.
Posted Oct 16, 2025 - 03:24 UTC
This incident affected: Paydock Platform (Paydock API, Paydock Dashboard).