MPGS Degraded Performance
Incident Report for Paydock
Resolved
After thorough monitoring, no MPGS system errors were detected in the past hour.

We have yet to receive a response from the MPGS gateway, but we are considering this incident resolved for now.
Posted Feb 11, 2023 - 10:44 UTC
Monitoring
The 3DS transaction process appears to have stabilised on the MPGS platform. There have been no occurrences of the "SERVER_FAILED" error in the last hour.

We are still keeping a close watch on the situation. If the error doesn't resurface in the next hour, we will consider the issue to have been resolved.
Posted Feb 11, 2023 - 09:41 UTC
Identified
We have identified a performance issue with one of our upstream providers (Mastercard) experiencing a degraded service. We are investigating and will provide updates as they become available.

We have raised a ticket with the MPGS team for further clarification.
Posted Feb 11, 2023 - 08:44 UTC
This incident affected: Payment Services (MPGS gateway).