MPGS Degraded Performance
Incident Report for Paydock
Resolved
We have received confirmation from the MPGS side that the MPGS Degraded Performance incident has been resolved. After careful monitoring, we haven't encountered any technical errors during the past hour.

However, the reason for the matter is still unclear as we haven't received any details from MPGS yet but we are considering this incident resolved at the moment.
Posted May 25, 2023 - 18:38 UTC
Monitoring
We are updating you on the MPGS incident we reported earlier. We haven't received any response from MPGS yet but we keep monitoring the situation.

At the moment, we can see that the percentage rate of failed charges has reduced to 40.74% for the last half an hour. We are closely looking at this matter and will provide updates once they are available.
Posted May 25, 2023 - 17:36 UTC
Identified
One of our upstream providers, MPGS, is currently facing a degraded service issue resulting in a 91 TIMED_OUT gateway code. We became aware of this problem at 4:25 PM UTC and it is still ongoing.

We are continuously monitoring the situation, and MPGS has been notified of the error, although we are yet to receive a response from them.

Based on our half-hour interval checks, error rates have been fluctuating between 73.08% and 94.74%. We are closely monitoring the incident and will provide updates as soon as they are available.
Posted May 25, 2023 - 17:04 UTC
This incident affected: Payment Services (MPGS gateway).