Intermittent connectivity issues to Paydock API
Incident Report for Paydock
Postmortem

There was a Sev 3 Incident that occurred yesterday (09/08/2023) between 9:30am and 11am AEST, this caused degradation on the Paydock side.

Paydock was receiving transactions as successful however for some customers (intermittently) were not receiving a timely response from the API, so it appears some customers tried putting a payment through again, which may have resulted in those customers being double charged.

We've already added some preventative measures overnight to prevent re-occurrence and we have some tasks in the backlog for overall and constant improvement.

If you have any further questions about this issue, please reach out to support@paydock.com

Posted Aug 10, 2023 - 04:39 UTC

Resolved
We have received reports that charges created from around 9:00am to 10:30am on 09/08/2023 AEST have intermittently had responses time out.

We can confirm that since 10:30am these issues haven't been observed, however we are still looking into potential causes for this, and we will provide updates via this channel.
Posted Aug 08, 2023 - 23:00 UTC