MPGS Degraded Performance
Incident Report for Paydock
Resolved
We have received an update from the MPGS team concerning the matter:

"We would like to inform you that a service disruption has been identified for Mastercard Payment Gateway Services due to which customers may experience transaction latency and intermittent transaction time outs/failures.

Impact Start: 06 May 2023, 01:22 CT (06:22 UTC)
Mastercard Reference No.: INC000000305088"

However, after closely monitoring the situation, we can confirm that there have been no MPGS system errors in the past hour.

As a result, we have decided to close this incident.
Posted May 06, 2023 - 10:27 UTC
Monitoring
Please be aware that the situation has stabilized over the last hour, and no further charges with system errors were observed.

However, we are yet to receive confirmation from MPGS that the incident is over. Therefore, we will continue to monitor the situation for another hour.

If no system errors occur during this time, we will consider that the incident has been resolved.
Posted May 06, 2023 - 09:33 UTC
Identified
At present, MPGS, one of our upstream providers, is experiencing a service issue that has caused an system error with the 4QRL52N23YQ2E MPGS Support Code. We were made aware of the problem at 7 AM UTC, and it is still persisting.

We are actively monitoring the situation, and we have informed MPGS about the error, but we have not yet received a response from them. As per our checks, which are conducted every half an hour, the error rates have been fluctuating between 6% and 22%.

We are keeping a close watch on the incident and will share further updates as soon as we receive them.
Posted May 06, 2023 - 08:07 UTC
This incident affected: Payment Services (MPGS gateway).