MPGS Degraded Performance
Incident Report for Paydock
Resolved
It has been confirmed that there were no MPGS system errors in the past 2 hours after careful monitoring.

We have received the communication from the MPGS gateway about the issue resolution confirming it is resolved. Hence we are closing this incident at this stage.
Posted Jun 27, 2023 - 19:09 UTC
Monitoring
We have received a reply from MPGS with a confirmation that there is a service disruption identified for Mastercard Payment Gateway Services (MPGS) Asia/Pacific gateway is ongoing. We haven't received any alerts on the failed charges on our side for the last hour; nevertheless, we are still monitoring the situation.
Posted Jun 27, 2023 - 17:04 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jun 27, 2023 - 16:02 UTC
Identified
At present, MPGS, one of our upstream providers, is experiencing a service issue that has caused a system error with the Payment service connection error. We were aware of the problem at 3:25 PM UTC, and it is still persisting.

We are actively monitoring the situation, and we have informed MPGS about the error, but we have not yet received a response from them. As per our checks, which are conducted every half an hour, the error rates have been fluctuating between 36.97% and 62.61%.

We are keeping a close watch on the incident and will share further updates as soon as we receive them.
Posted Jun 27, 2023 - 16:02 UTC
This incident affected: Payment Services (MPGS gateway).