MPGS Degraded Performance
Incident Report for Paydock
Resolved
Transaction process appears to have stabilised on the MPGS platform. We are yet to receive a response from the gateway, but for now we consider this incident to be resolved.
Posted Jul 30, 2022 - 05:09 UTC
Monitoring
We have identified a performance issue with one of our upstream providers (Mastercard) is experiencing a degraded service. We are investigating and will provide updates as they become available.

We have raised a ticket with MPGS for further clarification.
Posted Jul 29, 2022 - 20:04 UTC
This incident affected: Payment Services (MPGS gateway).